Server Reboot Scheduled
Incident Report for HomesUSA.com
Resolved
The Maintenance has been completed and the system is back online

Thanks for your patience.
Posted over 1 year ago. Feb 06, 2018 - 13:20 CST
Update
The reboot is taking longer than expected. Currently our team is investigating what is causing this delay. We will provide a new estimated time once the problem has been identified.

Sorry for the inconvenience
Posted over 1 year ago. Feb 06, 2018 - 12:05 CST
Investigating
The HomesUSA.com servers will go under maintenance on 2/6/2017 at 11:25 AM we expect them to be back at 11:45 AM

Sorry for the inconvenience.
Posted over 1 year ago. Feb 06, 2018 - 11:15 CST