HomesUSA Customer Support Temporarily Unavailable
Incident Report for HomesUSA.com
Resolved
Internet and phone connectivity at our main offices has been restored and limited Customer Support is available once again.
Posted over 2 years ago. Jan 19, 2017 - 12:13 CST
Identified
Due to a local Dallas-area internet and phone outage, HomesUSA Support is not currently available. We will be back to assist you as soon as our connections have been restored by our service provider.

PLEASE NOTE: All HomesUSA websites are unaffected by this outage and are fully accessible.
Posted over 2 years ago. Jan 19, 2017 - 10:20 CST